# CVE-2016-8741: Exposure of Sensitive Information to an Unauthorized Actor in Apache Qpid Broker for Java

> Remote attackers can enumerate valid user accounts in Apache Qpid Broker-J when SCRAM authentication is enabled due to premature SASL negotiation termination.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8vvh-crqv-jm64

## What is CVE-2016-8741?

CVE-2016-8741 is a high-severity vulnerability in Apache Qpid Broker-J, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Qpid Broker for Java can be configured to use different so called AuthenticationProviders to handle user authentication. Among the choices are the SCRAM-SHA-1 and SCRAM-SHA-256 AuthenticationProvider types. It was discovered that these AuthenticationProviders in Apache Qpid Broker for Java 6.0.x before 6.0.6 and 6.1.x before 6.1.1 prematurely terminate the SCRAM SASL negotiation if the provided user name does not exist thus allowing remote attacker to determine the existence of user accounts. The Vulnerability does not apply to AuthenticationProviders other than SCRAM-SHA-1 and SCRAM-SHA-256.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-8741?

4 open source packages ship an affected version, including org.apache.qpid:qpid-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:qpid-broker` | Maven | From 6.0.0 | 6.0.6 |
| `org.apache.qpid:qpid-broker` | Maven | From 6.0.0 | 6.0.6 |
| `org.apache.qpid:qpid-broker` | Maven | From 6.1.0 | 6.1.1 |
| `org.apache.qpid:qpid-broker` | Maven | From 6.1.0 | 6.1.1 |

Products: Apache Qpid Broker-J.

## How do I fix CVE-2016-8741?

Upgrade org.apache.qpid:qpid-broker to a fixed version for your release line: 6.0.6 or 6.1.1.

## Is CVE-2016-8741 being exploited?

There is no known exploitation of CVE-2016-8741 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid Broker-J

- [CVE-2026-92609](https://insights.sbomify.com/CVE-2026-92609/): Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication (critical 9.8)
- [CVE-2017-15702](https://insights.sbomify.com/CVE-2017-15702/): Apache Qpid Broker vulnerable to authentication port spoofing (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8741 and fix it if it is affected.

What it is: CVE-2016-8741 is a high-severity vulnerability in Apache Qpid Broker-J, published on 15 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-8741 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:qpid-broker (Maven): affected from 6.0.0; fixed in 6.0.6
- org.apache.qpid:qpid-broker (Maven): affected from 6.0.0; fixed in 6.0.6
- org.apache.qpid:qpid-broker (Maven): affected from 6.1.0; fixed in 6.1.1
- org.apache.qpid:qpid-broker (Maven): affected from 6.1.0; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8741/ (Markdown: https://insights.sbomify.com/CVE-2016-8741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8741
- OSV: https://osv.dev/vulnerability/CVE-2016-8741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8741/
Summaries are generated and may contain mistakes; the official description above is the record.
