{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.brooklyn:brooklyn. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-8744 in the wild and no public exploit code.","fix":"Upgrade org.apache.brooklyn:brooklyn to 0.10.0 or later.","what":"CVE-2016-8744 is a high-severity unsafe deserialization vulnerability in Apache Brooklyn, published on 13 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-8744 and fix it if it is affected.\n\nWhat it is: CVE-2016-8744 is a high-severity unsafe deserialization vulnerability in Apache Brooklyn, published on 13 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-8744 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.brooklyn:brooklyn (Maven): affected all versions; fixed in 0.10.0\n- org.apache.brooklyn:brooklyn (Maven): affected all versions; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8744/ (Markdown: https://insights.sbomify.com/CVE-2016-8744/index.md)","id":"CVE-2016-8744","markdown":"https://insights.sbomify.com/CVE-2016-8744/index.md","name":"CVE-2016-8744","record":{"aliases":["GHSA-9cqh-5x6g-wgm9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Brooklyn","requires_auth":"low_privilege","summary":"An authenticated user can exploit unsafe YAML deserialization in Apache Brooklyn to execute arbitrary Java code with system privileges.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"brooklyn","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Apache Brooklyn uses the SnakeYAML library for parsing YAML inputs. SnakeYAML allows the use of YAML tags to indicate that SnakeYAML should unmarshal data to a Java type. In the default configuration in Brooklyn before 0.10.0, SnakeYAML will allow unmarshalling to any Java type available on the classpath. This could provide an authenticated user with a means to cause the JVM running Brooklyn to load and run Java code without detection by Brooklyn. Such code would have the privileges of the Java process running Brooklyn, including the ability to open files and network connections, and execute system commands. There is known to be a proof-of-concept exploit using this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data in Apache Brooklyn","id":"CVE-2016-8744","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Concurrent Execution using Shared Resource with Improper Synchronization in Apache Tomcat","id":"CVE-2016-8745"},"packages":[{"ecosystem":"Maven","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.brooklyn:brooklyn","purl":null,"source":"GHSA-9cqh-5x6g-wgm9"},{"ecosystem":"Maven","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.brooklyn:brooklyn","purl":"pkg:maven/org.apache.brooklyn/brooklyn","source":"GHSA-9cqh-5x6g-wgm9"}],"prev":{"headline":"Other in Apache HTTP Server","id":"CVE-2016-8743"},"products":["Apache Brooklyn"],"published":"2017-09-13","related":[{"cvss_score":8.8,"headline":"Apache Brooklyn is vulnerable to cross-site request forgery (CSRF)","id":"CVE-2016-8737","kev_date_added":null,"published":"2017-09-13"},{"cvss_score":5.4,"headline":"Cross-site Scripting In Apache Brooklyn","id":"CVE-2017-3165","kev_date_added":null,"published":"2017-09-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"An authenticated user can exploit unsafe YAML deserialization in Apache Brooklyn to execute arbitrary Java code with system privileges.","url":"https://insights.sbomify.com/CVE-2016-8744/"}