# CVE-2016-8744: Deserialization of Untrusted Data in Apache Brooklyn

> An authenticated user can exploit unsafe YAML deserialization in Apache Brooklyn to execute arbitrary Java code with system privileges.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-9cqh-5x6g-wgm9

## What is CVE-2016-8744?

CVE-2016-8744 is a high-severity unsafe deserialization vulnerability in Apache Brooklyn, published on 13 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Brooklyn uses the SnakeYAML library for parsing YAML inputs. SnakeYAML allows the use of YAML tags to indicate that SnakeYAML should unmarshal data to a Java type. In the default configuration in Brooklyn before 0.10.0, SnakeYAML will allow unmarshalling to any Java type available on the classpath. This could provide an authenticated user with a means to cause the JVM running Brooklyn to load and run Java code without detection by Brooklyn. Such code would have the privileges of the Java process running Brooklyn, including the ability to open files and network connections, and execute system commands. There is known to be a proof-of-concept exploit using this vulnerability.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2016-8744?

2 open source packages ship an affected version, including org.apache.brooklyn:brooklyn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.brooklyn:brooklyn` | Maven | All versions | 0.10.0 |
| `org.apache.brooklyn:brooklyn` | Maven | All versions | 0.10.0 |

Products: Apache Brooklyn.

## How do I fix CVE-2016-8744?

Upgrade org.apache.brooklyn:brooklyn to 0.10.0 or later.

## Is CVE-2016-8744 being exploited?

There is no known exploitation of CVE-2016-8744 in the wild and no public exploit code.

## Other vulnerabilities in Apache Brooklyn

- [CVE-2016-8737](https://insights.sbomify.com/CVE-2016-8737/): Apache Brooklyn is vulnerable to cross-site request forgery (CSRF) (high 8.8)
- [CVE-2017-3165](https://insights.sbomify.com/CVE-2017-3165/): Cross-site Scripting In Apache Brooklyn (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8744 and fix it if it is affected.

What it is: CVE-2016-8744 is a high-severity unsafe deserialization vulnerability in Apache Brooklyn, published on 13 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-8744 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.brooklyn:brooklyn (Maven): affected all versions; fixed in 0.10.0
- org.apache.brooklyn:brooklyn (Maven): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8744/ (Markdown: https://insights.sbomify.com/CVE-2016-8744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8744
- OSV: https://osv.dev/vulnerability/CVE-2016-8744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8744/
Summaries are generated and may contain mistakes; the official description above is the record.
