CVE-2016-8748 Cross-site Scripting in Apache NiFi

Medium 5.4 Published Updated

An attacker can execute arbitrary scripts in the context of an authorized user's browser via the connection details dialog in Apache NiFi.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-8748?

CVE-2016-8748 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 19 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Weakness: CWE-79

Which versions are affected by CVE-2016-8748?

4 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.

PackageAffectedFixed in
org.apache.nifi:nifi MavenAll versions1.0.1
org.apache.nifi:nifi MavenAll versions1.0.1
org.apache.nifi:nifi MavenFrom 1.1.01.1.1
org.apache.nifi:nifi MavenFrom 1.1.01.1.1

Products include Apache Nifi.

How do I fix CVE-2016-8748?

Upgrade org.apache.nifi:nifi to a fixed version for your release line: 1.0.1 or 1.1.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2016-8748 being exploited?

There is no known exploitation of CVE-2016-8748 in the wild and no public exploit code.

All Apache Nifi vulnerabilities

Sources

Also known as GHSA-g2fm-x3cp-mqw9.

Is CVE-2016-8748 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free