CVE-2016-9013 Django user with hardcoded password created when running tests on Oracle
Django uses a hardcoded password for temporary Oracle test database users, allowing attackers to access the database if test settings are not manually configured.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9013?
CVE-2016-9013 is a critical vulnerability in Canonical Ubuntu Linux, published on 9 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Django 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3 use a hardcoded password for a temporary database user created when running tests with an Oracle database, which makes it easier for remote attackers to obtain access to the database server by leveraging failure to manually specify a password in the database settings TEST dictionary.
Weakness: CWE-798
Which versions are affected by CVE-2016-9013?
7 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.10a1 | 1.10.3 |
django PyPI | From 1.8 | 1.8.16, 1.9.11, 1.10.3 |
django PyPI | From 1.8a1 | 1.8.16 |
django PyPI | From 1.9a1 | 1.9.11 |
Django PyPI | From 1.10a1 | 1.10.3 |
Django PyPI | From 1.8a1 | 1.8.16 |
1 more packages
Django PyPI | From 1.9a1 | 1.9.11 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2016-9013?
Upgrade django to a fixed version for your release line: 1.10.3, 1.8.16 or 1.9.11.
Is CVE-2016-9013 being exploited?
There is no known exploitation of CVE-2016-9013 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2016-9013, DEBIAN-CVE-2016-9013, GHSA-mv8g-fhh6-6267, PYSEC-2016-17, UBUNTU-CVE-2016-9013.