# CVE-2016-9013: Django user with hardcoded password created when running tests on Oracle

> Django uses a hardcoded password for temporary Oracle test database users, allowing attackers to access the database if test settings are not manually configured.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** ALPINE-CVE-2016-9013, DEBIAN-CVE-2016-9013, GHSA-mv8g-fhh6-6267, PYSEC-2016-17, UBUNTU-CVE-2016-9013

## What is CVE-2016-9013?

CVE-2016-9013 is a critical vulnerability in Canonical Ubuntu Linux, published on 9 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Django 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3 use a hardcoded password for a temporary database user created when running tests with an Oracle database, which makes it easier for remote attackers to obtain access to the database server by leveraging failure to manually specify a password in the database settings TEST dictionary.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2016-9013?

7 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.10a1 | 1.10.3 |
| `django` | PyPI | From 1.8 | 1.8.16, 1.9.11, 1.10.3 |
| `django` | PyPI | From 1.8a1 | 1.8.16 |
| `django` | PyPI | From 1.9a1 | 1.9.11 |
| `Django` | PyPI | From 1.10a1 | 1.10.3 |
| `Django` | PyPI | From 1.8a1 | 1.8.16 |
| `Django` | PyPI | From 1.9a1 | 1.9.11 |

Products: Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2016-9013?

Upgrade django to a fixed version for your release line: 1.10.3, 1.8.16 or 1.9.11.

## Is CVE-2016-9013 being exploited?

There is no known exploitation of CVE-2016-9013 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9013 and fix it if it is affected.

What it is: CVE-2016-9013 is a critical vulnerability in Canonical Ubuntu Linux, published on 9 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9013 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.10a1; fixed in 1.10.3
- django (PyPI): affected from 1.8; fixed in 1.8.16, 1.9.11, 1.10.3
- django (PyPI): affected from 1.8a1; fixed in 1.8.16
- django (PyPI): affected from 1.9a1; fixed in 1.9.11
- Django (PyPI): affected from 1.10a1; fixed in 1.10.3
- Django (PyPI): affected from 1.8a1; fixed in 1.8.16
- Django (PyPI): affected from 1.9a1; fixed in 1.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9013/ (Markdown: https://insights.sbomify.com/CVE-2016-9013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9013
- OSV: https://osv.dev/vulnerability/CVE-2016-9013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9013/
Summaries are generated and may contain mistakes; the official description above is the record.
