CVE-2016-9014 Django DNS Rebinding Vulnerability
Attackers can bypass Host header validation in Django when debug mode is enabled, facilitating DNS rebinding attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9014?
CVE-2016-9014 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 9 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Django before 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3, when settings.DEBUG is True, allow remote attackers to conduct DNS rebinding attacks by leveraging failure to validate the HTTP Host header against settings.ALLOWED_HOSTS.
Weakness: CWE-264
Which versions are affected by CVE-2016-9014?
7 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.8.16, 1.9.11, 1.10.3 |
django PyPI | From 1.10a1 | 1.10.3 |
django PyPI | From 1.8a1 | 1.8.16 |
django PyPI | From 1.9a1 | 1.9.11 |
Django PyPI | From 1.10a1 | 1.10.3 |
Django PyPI | From 1.8a1 | 1.8.16 |
1 more packages
Django PyPI | From 1.9a1 | 1.9.11 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2016-9014?
Upgrade django to a fixed version for your release line: 1.8.16, 1.9.11 or 1.10.3.
Is CVE-2016-9014 being exploited?
There is no known exploitation of CVE-2016-9014 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2016-9014, DEBIAN-CVE-2016-9014, DLA-706-1, GHSA-3f2c-jm6v-cr35, PYSEC-2016-18, UBUNTU-CVE-2016-9014.