# CVE-2016-9014: Django DNS Rebinding Vulnerability

> Attackers can bypass Host header validation in Django when debug mode is enabled, facilitating DNS rebinding attacks.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** ALPINE-CVE-2016-9014, DEBIAN-CVE-2016-9014, DLA-706-1, GHSA-3f2c-jm6v-cr35, PYSEC-2016-18, UBUNTU-CVE-2016-9014

## What is CVE-2016-9014?

CVE-2016-9014 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 9 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Django before 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3, when settings.DEBUG is True, allow remote attackers to conduct DNS rebinding attacks by leveraging failure to validate the HTTP Host header against settings.ALLOWED_HOSTS.

Weakness: CWE-264

## Which versions are affected by CVE-2016-9014?

7 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.8.16, 1.9.11, 1.10.3 |
| `django` | PyPI | From 1.10a1 | 1.10.3 |
| `django` | PyPI | From 1.8a1 | 1.8.16 |
| `django` | PyPI | From 1.9a1 | 1.9.11 |
| `Django` | PyPI | From 1.10a1 | 1.10.3 |
| `Django` | PyPI | From 1.8a1 | 1.8.16 |
| `Django` | PyPI | From 1.9a1 | 1.9.11 |

Products: Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2016-9014?

Upgrade django to a fixed version for your release line: 1.8.16, 1.9.11 or 1.10.3.

## Is CVE-2016-9014 being exploited?

There is no known exploitation of CVE-2016-9014 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9014 and fix it if it is affected.

What it is: CVE-2016-9014 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 9 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9014 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.8.16, 1.9.11, 1.10.3
- django (PyPI): affected from 1.10a1; fixed in 1.10.3
- django (PyPI): affected from 1.8a1; fixed in 1.8.16
- django (PyPI): affected from 1.9a1; fixed in 1.9.11
- Django (PyPI): affected from 1.10a1; fixed in 1.10.3
- Django (PyPI): affected from 1.8a1; fixed in 1.8.16
- Django (PyPI): affected from 1.9a1; fixed in 1.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9014/ (Markdown: https://insights.sbomify.com/CVE-2016-9014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9014
- OSV: https://osv.dev/vulnerability/CVE-2016-9014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9014/
Summaries are generated and may contain mistakes; the official description above is the record.
