# CVE-2016-9015: Urllib3 Incorrect Certificate Validation

> Attackers can perform man-in-the-middle attacks and leak information due to improper TLS certificate validation in specific uncommon configurations.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v4w5-p2hg-8fh6, PYSEC-2017-98, SUSE-RU-2019:2627-1, SUSE-SU-2019:0139-1, openSUSE-SU-2024:10540-1

## What is CVE-2016-9015?

CVE-2016-9015 is a low-severity vulnerability in n/a, published on 11 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-9015?

3 open source packages ship an affected version, including urllib3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urllib3` | PyPI | From 1.17 | 1.18.1 |
| `urllib3` | PyPI | From 1.17 | 1.18.1 |
| `urllib3` | PyPI | From 1.17 | 1.18.1 |
| `python-rsa` | SUSE:Enterprise Storage 4 | All versions | 3.1.4-12.9.17 |
| `python-urllib3` | SUSE:Enterprise Storage 4 | All versions | 1.22-3.10.1 |
| `python-rsa` | SUSE:Enterprise Storage 5 | All versions | 3.1.4-12.9.17 |
| `python-urllib3` | SUSE:Enterprise Storage 5 | All versions | 1.22-3.10.1 |
| `python-oauthlib` | SUSE:HPE Helion OpenStack 8 | All versions | 0.7.2-3.9.20 |
| `python-setuptools` | SUSE:Linux Enterprise Desktop 12 SP4 | All versions | 40.6.2-4.12.23 |
| `python-setuptools` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 40.6.2-4.12.23 |
| `python-PyJWT` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.4.2-3.10.27 |
| `python-cliff` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.14.0-11.3.2 |
| `python-mock` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 2.0.0-3.7.25 |
| `python-oauthlib` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.7.2-3.9.20 |
| `python-pbr` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 3.1.1-3.5.2 |
| `python-rsa` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 3.1.4-12.9.17 |
| `python-setuptools` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 40.6.2-4.12.23 |
| `python-stevedore` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.8.0-16.2.1 |
| `python-urllib3` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.22-3.10.1 |
| `python-setuptools` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 40.6.2-4.12.23 |
| `python-setuptools` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 40.6.2-4.12.23 |
| `python-setuptools` | SUSE:Linux Enterprise Software Development Kit 12 SP4 | All versions | 40.6.2-4.12.23 |
| `python-urllib3` | SUSE:Manager Server 3.1 | All versions | 1.22-3.10.1 |
| `python-PyJWT` | SUSE:Manager Server 3.2 | All versions | 1.4.2-3.10.27 |
| `python-oauthlib` | SUSE:Manager Server 3.2 | All versions | 0.7.2-3.9.20 |
| `python-rsa` | SUSE:Manager Server 3.2 | All versions | 3.1.4-12.9.17 |
| `python-urllib3` | SUSE:Manager Server 3.2 | All versions | 1.22-3.10.1 |
| `python-PyJWT` | SUSE:OpenStack Cloud 7 | All versions | 1.4.2-3.10.27 |
| `python-oauthlib` | SUSE:OpenStack Cloud 7 | All versions | 0.7.2-3.9.20 |
| `python-rsa` | SUSE:OpenStack Cloud 7 | All versions | 3.1.4-12.9.17 |
| `python-setuptools` | SUSE:OpenStack Cloud 7 | All versions | 40.6.2-4.12.23 |
| `python-oauthlib` | SUSE:OpenStack Cloud 8 | All versions | 0.7.2-3.9.20 |
| `python-oauthlib` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 0.7.2-3.9.20 |
| `python3-urllib3` | openSUSE:Tumbleweed | All versions | 1.18.1-1.2 |

Products: Python Urllib3.

## How do I fix CVE-2016-9015?

Upgrade urllib3 to 1.18.1 or later.

## Is CVE-2016-9015 being exploited?

There is no known exploitation of CVE-2016-9015 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-97689](https://insights.sbomify.com/CVE-2026-97689/): urllib3: HTTPResponse.stream()/read_chunked() buffers an unbounded chunk-size line into memory (high 8.9)
- [CVE-2026-44432](https://insights.sbomify.com/CVE-2026-44432/): urllib3: Decompression-bomb safeguards bypassed in parts of the streaming API (high 8.9)
- [CVE-2026-21441](https://insights.sbomify.com/CVE-2026-21441/): urllib3 vulnerable to decompression-bomb safeguard bypass when following HTTP redirects (streaming API) (high 8.9)
- [CVE-2025-66418](https://insights.sbomify.com/CVE-2025-66418/): urllib3 allows an unbounded number of links in the decompression chain (high 8.9)
- [CVE-2025-66471](https://insights.sbomify.com/CVE-2025-66471/): urllib3 Streaming API improperly handles highly compressed data (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9015 and fix it if it is affected.

What it is: CVE-2016-9015 is a low-severity vulnerability in n/a, published on 11 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9015 in the wild and no public exploit code.

Affected packages and fixed versions:
- urllib3 (PyPI): affected from 1.17; fixed in 1.18.1
- urllib3 (PyPI): affected from 1.17; fixed in 1.18.1
- urllib3 (PyPI): affected from 1.17; fixed in 1.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9015/ (Markdown: https://insights.sbomify.com/CVE-2016-9015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9015
- OSV: https://osv.dev/vulnerability/CVE-2016-9015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9015/
Summaries are generated and may contain mistakes; the official description above is the record.
