# CVE-2016-9122: Go JOSE Signature Validation Bypass

> Attackers can exploit multiple signatures to confuse validation logic, potentially bypassing security checks in applications using the go-jose library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-9122, GHSA-77gc-fj98-665h, GO-2022-0945

## What is CVE-2016-9122?

CVE-2016-9122 is a high-severity vulnerability in Go JOSE All versions before 1.0.4, published on 28 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-jose before 1.0.4 suffers from multiple signatures exploitation. The go-jose library supports messages with multiple signatures. However, when validating a signed message the API did not indicate which signature was valid, which could potentially lead to confusion. For example, users of the library might mistakenly read protected header values from an attached signature that was different from the one originally validated.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-9122?

3 open source packages ship an affected version, including gopkg.in/square/go-jose.v1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gopkg.in/square/go-jose.v1` | Go | All versions | 1.1.0 |
| `gopkg.in/square/go-jose.v1` | Go | All versions | 1.1.0 |
| `gopkg.in/square/go-jose.v1` | Go | All versions | 1.1.0 |

Products: Go-Jose Project Go-Jose.

## How do I fix CVE-2016-9122?

Upgrade gopkg.in/square/go-jose.v1 to 1.1.0 or later.

## Is CVE-2016-9122 being exploited?

There is no known exploitation of CVE-2016-9122 in the wild and no public exploit code.

## Other vulnerabilities in Go JOSE All versions before 1.0.4

- [CVE-2016-9121](https://insights.sbomify.com/CVE-2016-9121/): Elliptic Curve Key Disclosure in go-jose (critical 9.1)
- [CVE-2026-34986](https://insights.sbomify.com/CVE-2026-34986/): Go JOSE affect by a panic in JWE decryption (high 7.5)
- [CVE-2016-9123](https://insights.sbomify.com/CVE-2016-9123/): Integer Overflow in go-jose (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9122 and fix it if it is affected.

What it is: CVE-2016-9122 is a high-severity vulnerability in Go JOSE All versions before 1.0.4, published on 28 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9122 in the wild and no public exploit code.

Affected packages and fixed versions:
- gopkg.in/square/go-jose.v1 (Go): affected all versions; fixed in 1.1.0
- gopkg.in/square/go-jose.v1 (Go): affected all versions; fixed in 1.1.0
- gopkg.in/square/go-jose.v1 (Go): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9122/ (Markdown: https://insights.sbomify.com/CVE-2016-9122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9122
- OSV: https://osv.dev/vulnerability/CVE-2016-9122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9122/
Summaries are generated and may contain mistakes; the official description above is the record.
