# CVE-2016-9177: Spark allows remote attackers to read arbitrary files via a .. (dot dot) in the URI

> Remote attackers can read arbitrary files via directory traversal in Spark, potentially exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-89gc-6cw6-4vch

## What is CVE-2016-9177?

CVE-2016-9177 is a high-severity path traversal vulnerability in n/a, published on 4 Nov 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Spark 2.5 allows remote attackers to read arbitrary files via a .. (dot dot) in the URI.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-9177?

2 open source packages ship an affected version, including com.sparkjava:spark-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.sparkjava:spark-core` | Maven | All versions | 2.5.2 |
| `com.sparkjava:spark-core` | Maven | All versions | 2.5.2 |

Products: Sparkjava Spark.

## How do I fix CVE-2016-9177?

Upgrade com.sparkjava:spark-core to 2.5.2 or later.

## Is CVE-2016-9177 being exploited?

There is no known exploitation of CVE-2016-9177 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/perwendel__spark_CVE-2016-9177_2-5-1 (github_poc): https://github.com/shoucheng3/perwendel__spark_CVE-2016-9177_2-5-1

## Other vulnerabilities in n/a

- [CVE-2018-9159](https://insights.sbomify.com/CVE-2018-9159/): Moderate severity vulnerability that affects com.sparkjava:spark-core (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9177 and fix it if it is affected.

What it is: CVE-2016-9177 is a high-severity path traversal vulnerability in n/a, published on 4 Nov 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9177 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.sparkjava:spark-core (Maven): affected all versions; fixed in 2.5.2
- com.sparkjava:spark-core (Maven): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9177/ (Markdown: https://insights.sbomify.com/CVE-2016-9177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9177
- OSV: https://osv.dev/vulnerability/CVE-2016-9177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9177/
Summaries are generated and may contain mistakes; the official description above is the record.
