{"answers":{"affected":"3 open source packages ship an affected version, including pillow and Pillow. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-9190 in the wild and no public exploit code.","fix":"Upgrade pillow to 3.3.2 or later.","what":"CVE-2016-9190 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 4 Nov 2016. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-9190 and fix it if it is affected.\n\nWhat it is: CVE-2016-9190 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 4 Nov 2016. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-9190 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pillow (PyPI): affected all versions; fixed in 3.3.2\n- pillow (PyPI): affected all versions; fixed in 3.3.2\n- Pillow (PyPI): affected all versions; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9190/ (Markdown: https://insights.sbomify.com/CVE-2016-9190/index.md)","id":"CVE-2016-9190","markdown":"https://insights.sbomify.com/CVE-2016-9190/index.md","name":"CVE-2016-9190","record":{"aliases":["DEBIAN-CVE-2016-9190","GHSA-w4vg-rf63-f3j3","PYSEC-2016-9","UBUNTU-CVE-2016-9190"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python image library","requires_auth":"none","summary":"Attackers can execute arbitrary code via crafted image files due to an insecure sign extension flaw in the Pillow library.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"pillow","vendor":"python"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Pillow before 3.3.2 allows context-dependent attackers to execute arbitrary code by using the \"crafted image file\" approach, related to an \"Insecure Sign Extension\" issue affecting the ImagingNew in Storage.c component.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary code using \"crafted image file\" approach affecting Pillow","id":"CVE-2016-9190","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux","python:pillow"],"type":"memory_corruption","year":"2016"},"n_packages":3,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-9191"},"packages":[{"ecosystem":"PyPI","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"Pillow","purl":null,"source":"GHSA-w4vg-rf63-f3j3"},{"ecosystem":"PyPI","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"GHSA-w4vg-rf63-f3j3"},{"ecosystem":"PyPI","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"PYSEC-2016-9"}],"prev":{"headline":"Pillow Integer overflow in Map.c","id":"CVE-2016-9189"},"products":["n/a"],"published":"2016-11-04","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via crafted image files due to an insecure sign extension flaw in the Pillow library.","url":"https://insights.sbomify.com/CVE-2016-9190/"}