# CVE-2016-9190: Arbitrary code using "crafted image file" approach affecting Pillow

> Attackers can execute arbitrary code via crafted image files due to an insecure sign extension flaw in the Pillow library.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Nov 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-9190, GHSA-w4vg-rf63-f3j3, PYSEC-2016-9, UBUNTU-CVE-2016-9190

## What is CVE-2016-9190?

CVE-2016-9190 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 4 Nov 2016. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Pillow before 3.3.2 allows context-dependent attackers to execute arbitrary code by using the "crafted image file" approach, related to an "Insecure Sign Extension" issue affecting the ImagingNew in Storage.c component.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-9190?

3 open source packages ship an affected version, including pillow and Pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 3.3.2 |
| `pillow` | PyPI | All versions | 3.3.2 |
| `Pillow` | PyPI | All versions | 3.3.2 |

Products: Debian Debian Linux, Python Pillow.

## How do I fix CVE-2016-9190?

Upgrade pillow to 3.3.2 or later.

## Is CVE-2016-9190 being exploited?

There is no known exploitation of CVE-2016-9190 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9190 and fix it if it is affected.

What it is: CVE-2016-9190 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 4 Nov 2016. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-9190 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 3.3.2
- pillow (PyPI): affected all versions; fixed in 3.3.2
- Pillow (PyPI): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9190/ (Markdown: https://insights.sbomify.com/CVE-2016-9190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9190
- OSV: https://osv.dev/vulnerability/CVE-2016-9190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9190/
Summaries are generated and may contain mistakes; the official description above is the record.
