# CVE-2016-9194: A vulnerability in 802.11 Wireless Multimedia Extensions (WME) action frame processing in Cisco Wireless LAN Controller (WLC) Software could


- **Severity:** Medium 6.5 (`CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Apr 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-42rw-vphv-r65g

## What is CVE-2016-9194?

CVE-2016-9194 is a medium-severity vulnerability in Cisco Wireless LAN Controller, published on 6 Apr 2017. 

### Official description

A vulnerability in 802.11 Wireless Multimedia Extensions (WME) action frame processing in Cisco Wireless LAN Controller (WLC) Software could allow an unauthenticated, adjacent attacker to cause a denial of service (DoS) condition. The vulnerability is due to incomplete input validation of the 802.11 WME packet header. An attacker could exploit this vulnerability by sending malformed 802.11 WME frames to a targeted device. A successful exploit could allow the attacker to cause the WLC to reload unexpectedly. The fixed versions are 8.0.140.0, 8.2.130.0, and 8.3.111.0. Cisco Bug IDs: CSCva86353.

Weakness: CWE-399

## Which versions are affected by CVE-2016-9194?

It affects 6 products.


Products: Cisco Wireless Lan Controller, Cisco Wireless Lan Controller 6.0, Cisco Wireless Lan Controller 7.0, Cisco Wireless Lan Controller 7.1, Cisco Wireless Lan Controller 7.2, Cisco Wireless Lan Controller 7.4.

## How do I fix CVE-2016-9194?

No fix has been published for CVE-2016-9194 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-9194 being exploited?

There is no known exploitation of CVE-2016-9194 in the wild and no public exploit code.

## Other vulnerabilities in Cisco Wireless LAN Controller

- [CVE-2014-0703](https://insights.sbomify.com/CVE-2014-0703/): Race condition in n/a (critical 10.0)
- [CVE-2014-0706](https://insights.sbomify.com/CVE-2014-0706/): Cisco Wireless LAN Controller (WLC) devices 7.2 before 7.2.115.2, 7.3, and 7.4 before 7.4.110.0 allow remote attackers to cause a denial of (high 7.8)
- [CVE-2014-0707](https://insights.sbomify.com/CVE-2014-0707/): Cisco Wireless LAN Controller (WLC) devices 7.2, 7.3, and 7.4 before 7.4.110.0 allow remote attackers to cause a denial of service (device r (high 7.8)
- [CVE-2018-0417](https://insights.sbomify.com/CVE-2018-0417/): Cisco Wireless LAN Controller Software GUI Privilege Escalation Vulnerability (high 7.5)
- [CVE-2019-1796](https://insights.sbomify.com/CVE-2019-1796/): Cisco Wireless LAN Controller Software IAPP Message Handling Denial of Service Vulnerabilities (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9194 and fix it if it is affected.

What it is: CVE-2016-9194 is a medium-severity vulnerability in Cisco Wireless LAN Controller, published on 6 Apr 2017. 
Exploitation: There is no known exploitation of CVE-2016-9194 in the wild and no public exploit code.

Affected product: Cisco Wireless LAN Controller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9194/ (Markdown: https://insights.sbomify.com/CVE-2016-9194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9194
- OSV: https://osv.dev/vulnerability/CVE-2016-9194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9194/
Summaries are generated and may contain mistakes; the official description above is the record.
