CVE-2016-9299 Improper Neutralization of Special Elements used in an LDAP Query in Jenkins
Remote attackers can execute arbitrary code on Jenkins servers by sending crafted serialized Java objects that trigger LDAP queries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9299?
CVE-2016-9299 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 12 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers to execute arbitrary code via a crafted serialized Java object, which triggers an LDAP query to a third-party server.
Weakness: CWE-90
Which versions are affected by CVE-2016-9299?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.19.3 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.19.3 |
org.jenkins-ci.main:jenkins-core Maven | From 2.20 | 2.32 |
org.jenkins-ci.main:jenkins-core Maven | From 2.20 | 2.32 |
Products include Fedoraproject Fedora, Jenkins Jenkins.
How do I fix CVE-2016-9299?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.19.3 or 2.32.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2016-9299 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-9299 exists.
Public exploit code: 1 Metasploit module, 2 Exploit-DB entries and 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-2x9h-h3c4-wqqh, MGASA-2016-0406.