# CVE-2016-9299: Improper Neutralization of Special Elements used in an LDAP Query in Jenkins

> Remote attackers can execute arbitrary code on Jenkins servers by sending crafted serialized Java objects that trigger LDAP queries.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2x9h-h3c4-wqqh, MGASA-2016-0406

## What is CVE-2016-9299?

CVE-2016-9299 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 12 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers to execute arbitrary code via a crafted serialized Java object, which triggers an LDAP query to a third-party server.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2016-9299?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.19.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.19.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.20 | 2.32 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.20 | 2.32 |

Products: Fedoraproject Fedora, Jenkins Jenkins.

## How do I fix CVE-2016-9299?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.19.3 or 2.32.

## Is CVE-2016-9299 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-9299 exists.

Public exploit code:

- Jenkins CLI HTTP Java Deserialization Vulnerability (metasploit)
- Jenkins CLI - HTTP Java Deserialization (Metasploit) (exploitdb)
- Jenkins CLI - HTTP Java Deserialization (Metasploit) (exploitdb)
- https://github.com/r00t4dm/Jenkins-CVE-2016-9299 (github_poc): https://github.com/r00t4dm/Jenkins-CVE-2016-9299

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9299 and fix it if it is affected.

What it is: CVE-2016-9299 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 12 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-9299 exists.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.19.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.19.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.20; fixed in 2.32
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.20; fixed in 2.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9299/ (Markdown: https://insights.sbomify.com/CVE-2016-9299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9299
- OSV: https://osv.dev/vulnerability/CVE-2016-9299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9299/
Summaries are generated and may contain mistakes; the official description above is the record.
