CVE-2016-9449 Drupal sensitive information disclosure
Authenticated users can access sensitive taxonomy term information due to inconsistent access query tags in Drupal.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9449?
CVE-2016-9449 is a medium-severity vulnerability in Drupal Drupal, published on 25 Nov 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The taxonomy module in Drupal 7.x before 7.52 and 8.x before 8.2.3 might allow remote authenticated users to obtain sensitive information about taxonomy terms by leveraging inconsistent naming of access query tags.
Weakness: CWE-200
Which versions are affected by CVE-2016-9449?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0 | 7.52 |
drupal/core Packagist | From 7.0 | 7.52 |
drupal/core Packagist | From 8.0 | 8.2.3 |
drupal/core Packagist | From 8.0 | 8.2.3 |
drupal/drupal Packagist | From 7.0 | 7.52 |
drupal/drupal Packagist | From 7.0 | 7.52 |
2 more packages
drupal/drupal Packagist | From 8.0 | 8.2.3 |
drupal/drupal Packagist | From 8.0 | 8.2.3 |
Products include Drupal Drupal.
How do I fix CVE-2016-9449?
Upgrade drupal/core to a fixed version for your release line: 7.52 or 8.2.3.
Is CVE-2016-9449 being exploited?
There is no known exploitation of CVE-2016-9449 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as GHSA-p745-347h-hjfw, UBUNTU-CVE-2016-9449.