# CVE-2016-9449: Drupal sensitive information disclosure

> Authenticated users can access sensitive taxonomy term information due to inconsistent access query tags in Drupal.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p745-347h-hjfw, UBUNTU-CVE-2016-9449

## What is CVE-2016-9449?

CVE-2016-9449 is a medium-severity vulnerability in Drupal Drupal, published on 25 Nov 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The taxonomy module in Drupal 7.x before 7.52 and 8.x before 8.2.3 might allow remote authenticated users to obtain sensitive information about taxonomy terms by leveraging inconsistent naming of access query tags.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-9449?

8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.52 |
| `drupal/core` | Packagist | From 7.0 | 7.52 |
| `drupal/core` | Packagist | From 8.0 | 8.2.3 |
| `drupal/core` | Packagist | From 8.0 | 8.2.3 |
| `drupal/drupal` | Packagist | From 7.0 | 7.52 |
| `drupal/drupal` | Packagist | From 7.0 | 7.52 |
| `drupal/drupal` | Packagist | From 8.0 | 8.2.3 |
| `drupal/drupal` | Packagist | From 8.0 | 8.2.3 |

Products: Drupal Drupal.

## How do I fix CVE-2016-9449?

Upgrade drupal/core to a fixed version for your release line: 7.52 or 8.2.3.

## Is CVE-2016-9449 being exploited?

There is no known exploitation of CVE-2016-9449 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9449 and fix it if it is affected.

What it is: CVE-2016-9449 is a medium-severity vulnerability in Drupal Drupal, published on 25 Nov 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9449 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.52
- drupal/core (Packagist): affected from 7.0; fixed in 7.52
- drupal/core (Packagist): affected from 8.0; fixed in 8.2.3
- drupal/core (Packagist): affected from 8.0; fixed in 8.2.3
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.52
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.52
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.3
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9449/ (Markdown: https://insights.sbomify.com/CVE-2016-9449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9449
- OSV: https://osv.dev/vulnerability/CVE-2016-9449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9449/
Summaries are generated and may contain mistakes; the official description above is the record.
