# CVE-2016-9589: Red Hat Wildfly DoS

> Attackers can exhaust server memory via HTTP header cache exploitation in WildFly, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p4xg-cpr9-vwvj

## What is CVE-2016-9589?

CVE-2016-9589 is a high-severity denial of service vulnerability in Red Hat, Inc. wildfly, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Undertow in Red Hat wildfly before version 11.0.0.Beta1 is vulnerable to a resource exhaustion resulting in a denial of service. Undertow keeps a cache of seen HTTP headers in persistent connections. It was found that this cache can easily exploited to fill memory with garbage, up to "max-headers" (default 200) * "max-header-size" (default 1MB) per active TCP connection.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-9589?

2 open source packages ship an affected version, including org.wildfly:wildfly-undertow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wildfly:wildfly-undertow` | Maven | All versions | 11.0.0.Beta1 |
| `org.wildfly:wildfly-undertow` | Maven | All versions | 11.0.0.Beta1 |

Products: Redhat Jboss Wildfly Application Server.

## How do I fix CVE-2016-9589?

Upgrade org.wildfly:wildfly-undertow to 11.0.0.Beta1 or later.

## Is CVE-2016-9589 being exploited?

There is no known exploitation of CVE-2016-9589 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat, Inc. wildfly

- [CVE-2015-3198](https://insights.sbomify.com/CVE-2015-3198/): The Undertow module of WildFly allows source code disclosure (high 7.5)
- [CVE-2016-0793](https://insights.sbomify.com/CVE-2016-0793/): WildFly has incomplete blacklist vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9589 and fix it if it is affected.

What it is: CVE-2016-9589 is a high-severity denial of service vulnerability in Red Hat, Inc. wildfly, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9589 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wildfly:wildfly-undertow (Maven): affected all versions; fixed in 11.0.0.Beta1
- org.wildfly:wildfly-undertow (Maven): affected all versions; fixed in 11.0.0.Beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9589/ (Markdown: https://insights.sbomify.com/CVE-2016-9589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9589
- OSV: https://osv.dev/vulnerability/CVE-2016-9589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9589/
Summaries are generated and may contain mistakes; the official description above is the record.
