{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-9590 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-9590 is a medium-severity vulnerability in Redhat Openstack, published on 26 Apr 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-9590 and fix it if it is affected.\n\nWhat it is: CVE-2016-9590 is a medium-severity vulnerability in Redhat Openstack, published on 26 Apr 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-9590 in the wild and no public exploit code.\n\nAffected product: Redhat Openstack. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9590/ (Markdown: https://insights.sbomify.com/CVE-2016-9590/index.md)","id":"CVE-2016-9590","markdown":"https://insights.sbomify.com/CVE-2016-9590/index.md","name":"CVE-2016-9590","record":{"aliases":["DEBIAN-CVE-2016-9590","GHSA-7q5j-cmrw-cmmc","RHSA-2017:0200","RHSA-2017:0359","RHSA-2017:0361","UBUNTU-CVE-2016-9590"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenStack Swift Puppet module","requires_auth":"low_privilege","summary":"An information disclosure vulnerability in the puppet-swift module allows attackers to read sensitive configuration data due to world-readable file permissions.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"puppet-swift","vendor":"openstack"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.","ecosystems":["Red Hat:openstack:10::el7","Red Hat:openstack:8::el7","Red Hat:openstack:9::el7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in puppet-swift","id":"CVE-2016-9590","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"redhat:openstack","products":["redhat:openstack"],"type":"information_disclosure","year":"2016"},"n_packages":3,"n_references":5,"next":{"headline":"Use after free in jasper","id":"CVE-2016-9591"},"packages":[{"ecosystem":"Red Hat:openstack:10::el7","fixed":["0:9.4.3-3.el7ost"],"introduced":["0"],"last_affected":[],"package":"puppet-swift","purl":"pkg:rpm/redhat/puppet-swift","source":"RHSA-2017:0200"},{"ecosystem":"Red Hat:openstack:8::el7","fixed":["1:7.1.5-2.el7ost"],"introduced":["0"],"last_affected":[],"package":"openstack-puppet-modules","purl":"pkg:rpm/redhat/openstack-puppet-modules","source":"RHSA-2017:0361"},{"ecosystem":"Red Hat:openstack:9::el7","fixed":["1:8.1.10-2.el7ost"],"introduced":["0"],"last_affected":[],"package":"openstack-puppet-modules","purl":"pkg:rpm/redhat/openstack-puppet-modules","source":"RHSA-2017:0359"}],"prev":{"headline":"Red Hat Wildfly DoS","id":"CVE-2016-9589"},"products":["puppet-swift"],"published":"2018-04-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["unspecified"]},"summary":"An information disclosure vulnerability in the puppet-swift module allows attackers to read sensitive configuration data due to world-readable file permissions.","url":"https://insights.sbomify.com/CVE-2016-9590/"}