{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-9605 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2016-9605 is a medium-severity path traversal vulnerability in The cobbler Project cobbler, published on 22 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-9605 and fix it if it is affected.\n\nWhat it is: CVE-2016-9605 is a medium-severity path traversal vulnerability in The cobbler Project cobbler, published on 22 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-9605 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions up to 2.6.11-1; no fix listed\n- cobbler (PyPI): affected all versions up to 2.6.11-1; no fix listed\n- cobbler (PyPI): affected all versions up to 2.6.11-1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9605/ (Markdown: https://insights.sbomify.com/CVE-2016-9605/index.md)","id":"CVE-2016-9605","markdown":"https://insights.sbomify.com/CVE-2016-9605/index.md","name":"CVE-2016-9605","record":{"aliases":["GHSA-4vc9-4xpq-77vm","PYSEC-2026-623","SUSE-SU-2017:1699-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"An attacker can read arbitrary files from the server by exploiting a path traversal flaw in the Cobbler web interface.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cobbler","vendor":"cobbler_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.","ecosystems":["PyPI","SUSE:Manager Client Tools 12","SUSE:Manager Server 3.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler Arbitrary File Read","id":"CVE-2016-9605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2016"},"n_packages":5,"n_references":1,"next":{"headline":"JBoss RESTEasy vulnerable to Improper Input Validation","id":"CVE-2016-9606"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.6.11-1"],"package":"cobbler","purl":null,"source":"GHSA-4vc9-4xpq-77vm"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.6.11-1"],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-4vc9-4xpq-77vm"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.6.11-1"],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-623"},{"ecosystem":"SUSE:Manager Client Tools 12","fixed":["2.6.6-48.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Manager%20Client%20Tools%2012","source":"SUSE-SU-2017:1699-1"},{"ecosystem":"SUSE:Manager Server 3.0","fixed":["2.6.6-48.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Manager%20Server%203.0","source":"SUSE-SU-2017:1699-1"}],"prev":{"headline":"Privilege escalation in security","id":"CVE-2016-9604"},"products":["cobbler"],"published":"2018-08-22","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","kev_date_added":null,"published":"2018-08-09"},{"cvss_score":9.8,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":8.2,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":7.8,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["The cobbler Project"]},"summary":"An attacker can read arbitrary files from the server by exploiting a path traversal flaw in the Cobbler web interface.","url":"https://insights.sbomify.com/CVE-2016-9605/"}