# CVE-2016-9639: Salt allows deleted minions to read or write to minions with the same id

> Deleted minions can read or write to active minions with the same ID due to improper caching, allowing unauthorized data access and modification.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hvmj-356c-gpf4, PYSEC-2017-34, SUSE-RU-2017:0169-1, SUSE-RU-2017:0171-1, SUSE-RU-2017:0174-1, UBUNTU-CVE-2016-9639

## What is CVE-2016-9639?

CVE-2016-9639 is a critical missing authorization vulnerability in Saltstack Salt, published on 7 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Salt before 2015.8.11 allows deleted minions to read or write to minions with the same id, related to caching.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-9639?

3 open source packages ship an affected version, including salt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 2015.8.11 |
| `salt` | PyPI | All versions | 2015.8.11 |
| `salt` | PyPI | All versions | 2015.8.11 |
| `salt` | SUSE:Enterprise Storage 3 | All versions | 2015.8.12-27.5 |
| `salt` | SUSE:Enterprise Storage 4 | All versions | 2015.8.12-27.5 |
| `salt` | SUSE:Linux Enterprise Point of Sale 12 SP2 | All versions | 2015.8.12-27.5 |
| `osad` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 5.11.64.3-5.1 |
| `salt` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2015.8.12-27.1 |
| `spacewalk-backend` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2.5.24.7-16.1 |
| `supportutils-plugin-susemanager-client` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 3.0.5-5.1 |
| `osad` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 5.11.64.3-5.1 |
| `salt` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2015.8.12-27.1 |
| `spacewalk-backend` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2.5.24.7-16.1 |
| `supportutils-plugin-susemanager-client` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 3.0.5-5.1 |
| `salt` | SUSE:Manager Client Tools 12 | All versions | 2015.8.12-27.5 |
| `salt` | SUSE:Manager Proxy 3.0 | All versions | 2015.8.12-27.5 |
| `salt` | SUSE:Manager Server 3.0 | All versions | 2015.8.12-27.5 |

Products: Saltstack Salt.

## How do I fix CVE-2016-9639?

Upgrade salt to 2015.8.11 or later.

## Is CVE-2016-9639 being exploited?

There is no known exploitation of CVE-2016-9639 in the wild and no public exploit code.

## Other vulnerabilities in Saltstack Salt

- [CVE-2013-4437](https://insights.sbomify.com/CVE-2013-4437/): SaltStack insecurely uses /tmp (critical 10.0)
- [CVE-2013-6617](https://insights.sbomify.com/CVE-2013-6617/): SaltStack Privilege Escalation vulnerability (critical 10.0)
- [CVE-2021-33226](https://insights.sbomify.com/CVE-2021-33226/): Code injection in n/a (critical 9.8)
- [CVE-2021-25315](https://insights.sbomify.com/CVE-2021-25315/): salt-api unauthenticated remote code execution (critical 9.8)
- [CVE-2018-15751](https://insights.sbomify.com/CVE-2018-15751/): SaltStack Salt Remote command execution and incorrect access control when using salt-api (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9639 and fix it if it is affected.

What it is: CVE-2016-9639 is a critical missing authorization vulnerability in Saltstack Salt, published on 7 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-9639 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 2015.8.11
- salt (PyPI): affected all versions; fixed in 2015.8.11
- salt (PyPI): affected all versions; fixed in 2015.8.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9639/ (Markdown: https://insights.sbomify.com/CVE-2016-9639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9639
- OSV: https://osv.dev/vulnerability/CVE-2016-9639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9639/
Summaries are generated and may contain mistakes; the official description above is the record.
