{"answers":{"affected":"8 open source packages ship an affected version, including simplesamlphp/saml2. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-9814 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.8.1, 1.10.3, 1.9.1 or 2.3.3.","what":"CVE-2016-9814 is a critical vulnerability in n/a, published on 16 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-9814 and fix it if it is affected.\n\nWhat it is: CVE-2016-9814 is a critical vulnerability in n/a, published on 16 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-9814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.8.1\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.8.1\n- simplesamlphp/saml2 (Packagist): affected from 1.10; fixed in 1.10.3\n- simplesamlphp/saml2 (Packagist): affected from 1.10; fixed in 1.10.3\n- simplesamlphp/saml2 (Packagist): affected from 1.9.0; fixed in 1.9.1\n- simplesamlphp/saml2 (Packagist): affected from 1.9.0; fixed in 1.9.1\n- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.3\n- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9814/ (Markdown: https://insights.sbomify.com/CVE-2016-9814/index.md)","id":"CVE-2016-9814","markdown":"https://insights.sbomify.com/CVE-2016-9814/index.md","name":"CVE-2016-9814","record":{"aliases":["DEBIAN-CVE-2016-9814","GHSA-r8v4-7vwj-983x","UBUNTU-CVE-2016-9814"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SAML2 authentication library","requires_auth":"none","summary":"Remote attackers can spoof SAML responses or cause denial of service via improper boolean conversion in SimpleSAMLphp and saml2 libraries.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"saml2","vendor":"simplesamlphp"},{"product":"simplesamlphp","vendor":"simplesamlphp"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The validateSignature method in the SAML2\\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SimpleSAMLphp SAML2 spoof SAML responses","id":"CVE-2016-9814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":8,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-9815"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["1.10.3"],"introduced":["1.10"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["1.10.3"],"introduced":["1.10"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["1.9.1"],"introduced":["1.9.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["1.9.1"],"introduced":["1.9.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["2.3.3"],"introduced":["2.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-r8v4-7vwj-983x"},{"ecosystem":"Packagist","fixed":["2.3.3"],"introduced":["2.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-r8v4-7vwj-983x"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2016-9813"},"products":["n/a"],"published":"2017-02-16","related":[{"cvss_score":6.8,"headline":"Validation of SignedInfo","id":"CVE-2023-49087","kev_date_added":null,"published":"2023-11-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can spoof SAML responses or cause denial of service via improper boolean conversion in SimpleSAMLphp and saml2 libraries.","url":"https://insights.sbomify.com/CVE-2016-9814/"}