CVE-2016-9847 phpMyAdmin Cryptographic Vulnerability
Weak runtime generation of blowfish_secret allows attackers to decrypt user cookies, compromising session security in phpMyAdmin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9847?
CVE-2016-9847 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. When the user does not specify a blowfish_secret key for encrypting cookies, phpMyAdmin generates one at runtime. A vulnerability was reported where the way this value is created uses a weak algorithm. This could allow an attacker to determine the user's blowfish_secret and potentially decrypt their cookies. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Weakness: CWE-310
Which versions are affected by CVE-2016-9847?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-9847?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.18, 4.4.15.9 or 4.6.5.
Is CVE-2016-9847 being exploited?
There is no known exploitation of CVE-2016-9847 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-9847, CVE-2016-1000360, DEBIAN-CVE-2016-9847, GHSA-9xhq-pm7v-693p, UBUNTU-CVE-2016-9847.