{"answers":{"affected":"6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-9847 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.18, 4.4.15.9 or 4.6.5.","what":"CVE-2016-9847 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-9847 and fix it if it is affected.\n\nWhat it is: CVE-2016-9847 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-9847 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.18\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.18\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.9\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.9\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9847/ (Markdown: https://insights.sbomify.com/CVE-2016-9847/index.md)","id":"CVE-2016-9847","markdown":"https://insights.sbomify.com/CVE-2016-9847/index.md","name":"CVE-2016-9847","record":{"aliases":["ALPINE-CVE-2016-9847","CVE-2016-1000360","DEBIAN-CVE-2016-9847","GHSA-9xhq-pm7v-693p","UBUNTU-CVE-2016-9847"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Weak runtime generation of blowfish_secret allows attackers to decrypt user cookies, compromising session security in phpMyAdmin.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"An issue was discovered in phpMyAdmin. When the user does not specify a blowfish_secret key for encrypting cookies, phpMyAdmin generates one at runtime. A vulnerability was reported where the way this value is created uses a weak algorithm. This could allow an attacker to determine the user's blowfish_secret and potentially decrypt their cookies. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Cryptographic Vulnerability","id":"CVE-2016-9847","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"weak_cryptography","year":"2016"},"n_packages":6,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2016-9848"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.10.18"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-9xhq-pm7v-693p"},{"ecosystem":"Packagist","fixed":["4.0.10.18"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-9xhq-pm7v-693p"},{"ecosystem":"Packagist","fixed":["4.4.15.9"],"introduced":["4.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-9xhq-pm7v-693p"},{"ecosystem":"Packagist","fixed":["4.4.15.9"],"introduced":["4.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-9xhq-pm7v-693p"},{"ecosystem":"Packagist","fixed":["4.6.5"],"introduced":["4.6"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-9xhq-pm7v-693p"},{"ecosystem":"Packagist","fixed":["4.6.5"],"introduced":["4.6"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-9xhq-pm7v-693p"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-9846"},"products":["n/a"],"published":"2016-12-11","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Weak runtime generation of blowfish_secret allows attackers to decrypt user cookies, compromising session security in phpMyAdmin.","url":"https://insights.sbomify.com/CVE-2016-9847/"}