CVE-2016-9853 phpMyAdmin path disclosure
Attackers can trigger PHP errors to reveal the full installation path of phpMyAdmin, potentially aiding further attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9853?
CVE-2016-9853 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. By calling some scripts that are part of phpMyAdmin in an unexpected way, it is possible to trigger phpMyAdmin to display a PHP error message which contains the full path of the directory where phpMyAdmin is installed. During an execution timeout in the export functionality, the errors containing the full path of the directory of phpMyAdmin are written to the export file. All 4.6.x versions (prior to 4.6.5), and 4.4.x versions (prior to 4.4.15.9) are affected. This CVE is for the fopen wrapper issue.
Weakness: CWE-200
Which versions are affected by CVE-2016-9853?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.5 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.5 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-9853?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.4.15.9 or 4.6.5.
Is CVE-2016-9853 being exploited?
There is no known exploitation of CVE-2016-9853 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-9853, DEBIAN-CVE-2016-9853, GHSA-rmmf-5xhh-gg27, UBUNTU-CVE-2016-9853.