CVE-2016-9856 phpMyAdmin XSS Vulnerability
Cross-site scripting vulnerability in phpMyAdmin allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-9856?
CVE-2016-9856 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10. This issue is resolved by using a copy of a hash to avoid a race condition. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Weakness: CWE-79
Which versions are affected by CVE-2016-9856?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-9856?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.18, 4.4.15.9 or 4.6.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-9856 being exploited?
There is no known exploitation of CVE-2016-9856 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-9856, CVE-2016-1000366, DEBIAN-CVE-2016-9856, GHSA-j8mx-x32r-5rf4, UBUNTU-CVE-2016-9856.