CVE-2016-9860 phpMyAdmin Denial of Service (DoS)
Unauthenticated attackers can cause denial of service in phpMyAdmin when arbitrary server connections are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9860?
CVE-2016-9860 is a medium-severity denial of service vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. An unauthenticated user can execute a denial of service attack when phpMyAdmin is running with $cfg['AllowArbitraryServer']=true. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Weakness: CWE-20
Which versions are affected by CVE-2016-9860?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-9860?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.18, 4.4.15.9 or 4.6.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-9860 being exploited?
There is no known exploitation of CVE-2016-9860 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-9860, DEBIAN-CVE-2016-9860, GHSA-3hw5-fffc-qrg4, UBUNTU-CVE-2016-9860.