CVE-2016-9861 phpMyAdmin Bypass white-list protection for URL redirection
Attackers can bypass URL white-list protection in phpMyAdmin due to flawed URL matching logic, potentially accessing restricted resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9861?
CVE-2016-9861 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. Due to the limitation in URL matching, it was possible to bypass the URL white-list protection. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Weakness: CWE-254
Which versions are affected by CVE-2016-9861?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.5 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-9861?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.18, 4.4.15.9 or 4.6.5.
Is CVE-2016-9861 being exploited?
There is no known exploitation of CVE-2016-9861 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-9861, CVE-2016-1000368, DEBIAN-CVE-2016-9861, GHSA-r326-mp8g-6xfc, UBUNTU-CVE-2016-9861.