CVE-2016-9863 phpMyAdmin DoS Vulnerability

High 7.5 Published Updated

An attacker can cause a Denial of Service in phpMyAdmin by sending a very large request to the table partitioning function.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-9863?

CVE-2016-9863 is a high-severity denial of service vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in phpMyAdmin. With a very large request to table partitioning function, it is possible to invoke a Denial of Service (DoS) attack. All 4.6.x versions (prior to 4.6.5) are affected.

Weakness: CWE-20

Which versions are affected by CVE-2016-9863?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.

PackageAffectedFixed in
phpmyadmin/phpmyadmin PackagistFrom 4.6.04.6.5
phpmyadmin/phpmyadmin PackagistFrom 4.6.04.6.5

Products include Phpmyadmin Phpmyadmin.

How do I fix CVE-2016-9863?

Upgrade phpmyadmin/phpmyadmin to 4.6.5 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2016-9863 being exploited?

There is no known exploitation of CVE-2016-9863 in the wild and no public exploit code.

All Phpmyadmin Phpmyadmin vulnerabilities

Sources

Also known as ALPINE-CVE-2016-9863, CVE-2016-1000370, DEBIAN-CVE-2016-9863, GHSA-qgrq-64g6-mmh6.

Is CVE-2016-9863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free