CVE-2016-9866 phpMyAdmin CSRF Vulnerability
Attackers can bypass CSRF protection in phpMyAdmin preference imports when a non-default argument separator is configured.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-9866?
CVE-2016-9866 is a critical vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. When the arg_separator is different from its default & value, the CSRF token was not properly stripped from the return URL of the preference import action. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Weakness: CWE-352
Which versions are affected by CVE-2016-9866?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.18 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.9 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.5 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.5 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-9866?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.18, 4.4.15.9 or 4.6.5.
Is CVE-2016-9866 being exploited?
There is no known exploitation of CVE-2016-9866 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-9866, CVE-2016-1000373, DEBIAN-CVE-2016-9866, GHSA-jvxx-8xxf-5495, UBUNTU-CVE-2016-9866.