{"answers":{"affected":"3 open source packages ship an affected version, including html5lib. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-9909 in the wild and no public exploit code.","fix":"Upgrade html5lib to 0.999999999 or later.","what":"CVE-2016-9909 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-9909 and fix it if it is affected.\n\nWhat it is: CVE-2016-9909 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-9909 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- html5lib (PyPI): affected all versions; fixed in 0.999999999\n- html5lib (PyPI): affected all versions; fixed in 0.999999999\n- html5lib (PyPI): affected all versions; fixed in 0.999999999\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9909/ (Markdown: https://insights.sbomify.com/CVE-2016-9909/index.md)","id":"CVE-2016-9909","markdown":"https://insights.sbomify.com/CVE-2016-9909/index.md","name":"CVE-2016-9909","record":{"aliases":["DEBIAN-CVE-2016-9909","GHSA-v9v9-xffq-rwr4","PYSEC-2017-14","UBUNTU-CVE-2016-9909"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"HTML parsing library","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts via XSS due to mishandling of the less-than character in attribute values within the html5lib serializer.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"html5lib","vendor":"html5lib"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the \u003c (less than) character in attribute values.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in html5lib","id":"CVE-2016-9909","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2016"},"n_packages":3,"n_references":7,"next":{"headline":"Cross-site Scripting in html5lib","id":"CVE-2016-9910"},"packages":[{"ecosystem":"PyPI","fixed":["0.999999999"],"introduced":["0"],"last_affected":[],"package":"html5lib","purl":null,"source":"GHSA-v9v9-xffq-rwr4"},{"ecosystem":"PyPI","fixed":["0.999999999"],"introduced":["0"],"last_affected":[],"package":"html5lib","purl":"pkg:pypi/html5lib","source":"GHSA-v9v9-xffq-rwr4"},{"ecosystem":"PyPI","fixed":["0.999999999"],"introduced":["0"],"last_affected":[],"package":"html5lib","purl":"pkg:pypi/html5lib","source":"PYSEC-2017-14"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-9908"},"products":["n/a"],"published":"2017-02-22","related":[{"cvss_score":6.1,"headline":"Cross-site Scripting in html5lib","id":"CVE-2016-9910","kev_date_added":null,"published":"2017-02-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts via XSS due to mishandling of the less-than character in attribute values within the html5lib serializer.","url":"https://insights.sbomify.com/CVE-2016-9909/"}