CVE-2016-9910 Cross-site Scripting in html5lib

Medium 6.1 Published Updated

Remote attackers can execute arbitrary scripts via cross-site scripting due to mishandled special characters in attribute values within the html5lib serializer.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-9910?

CVE-2016-9910 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Weakness: CWE-79

Which versions are affected by CVE-2016-9910?

3 open source packages ship an affected version, including html5lib. It affects 1 product.

PackageAffectedFixed in
html5lib PyPIAll versions0.99999999
html5lib PyPIAll versions0.99999999
html5lib PyPIAll versions0.999999999

Products include Html5lib Html5lib.

How do I fix CVE-2016-9910?

Upgrade html5lib to a fixed version for your release line: 0.99999999 or 0.999999999.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2016-9910 being exploited?

There is no known exploitation of CVE-2016-9910 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2016-9910, GHSA-8f6m-gfq9-g33v, PYSEC-2017-15, UBUNTU-CVE-2016-9910.

Is CVE-2016-9910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free