# CVE-2016-9910: Cross-site Scripting in html5lib

> Remote attackers can execute arbitrary scripts via cross-site scripting due to mishandled special characters in attribute values within the html5lib serializer.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-9910, GHSA-8f6m-gfq9-g33v, PYSEC-2017-15, UBUNTU-CVE-2016-9910

## What is CVE-2016-9910?

CVE-2016-9910 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-9910?

3 open source packages ship an affected version, including html5lib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html5lib` | PyPI | All versions | 0.99999999 |
| `html5lib` | PyPI | All versions | 0.99999999 |
| `html5lib` | PyPI | All versions | 0.999999999 |

Products: Html5lib Html5lib.

## How do I fix CVE-2016-9910?

Upgrade html5lib to a fixed version for your release line: 0.99999999 or 0.999999999.

## Is CVE-2016-9910 being exploited?

There is no known exploitation of CVE-2016-9910 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-9909](https://insights.sbomify.com/CVE-2016-9909/): Improper Neutralization of Input During Web Page Generation in html5lib (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-9910 and fix it if it is affected.

What it is: CVE-2016-9910 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-9910 in the wild and no public exploit code.

Affected packages and fixed versions:
- html5lib (PyPI): affected all versions; fixed in 0.99999999
- html5lib (PyPI): affected all versions; fixed in 0.99999999
- html5lib (PyPI): affected all versions; fixed in 0.999999999

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-9910/ (Markdown: https://insights.sbomify.com/CVE-2016-9910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-9910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-9910
- OSV: https://osv.dev/vulnerability/CVE-2016-9910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-9910/
Summaries are generated and may contain mistakes; the official description above is the record.
