{"answers":{"affected":"2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-9955 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/simplesamlphp to 1.14.11 or later.","what":"CVE-2016-9955 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Feb 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-9955 and fix it if it is affected.\n\nWhat it is: CVE-2016-9955 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Feb 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-9955 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.11\n- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-9955/ (Markdown: https://insights.sbomify.com/CVE-2016-9955/index.md)","id":"CVE-2016-9955","markdown":"https://insights.sbomify.com/CVE-2016-9955/index.md","name":"CVE-2016-9955","record":{"aliases":["DEBIAN-CVE-2016-9955","GHSA-p9cm-r7jg-8q3g","UBUNTU-CVE-2016-9955"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"SAML authentication library","requires_auth":"none","summary":"Remote attackers can spoof SAML signatures or cause denial of service via improper boolean conversion in SimpleSAMLphp.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"simplesamlphp","vendor":"simplesamlphp"}],"cvss":{"score":6.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The SimpleSAML_XML_Validator class constructor in SimpleSAMLphp before 1.14.11 might allow remote attackers to spoof signatures on SAML 1 responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect signature verification in SimpleSAMLphp","id":"CVE-2016-9955","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"security_feature_bypass","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"Path traversal in n/a","id":"CVE-2016-9956"},"packages":[{"ecosystem":"Packagist","fixed":["1.14.11"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp","purl":null,"source":"GHSA-p9cm-r7jg-8q3g"},{"ecosystem":"Packagist","fixed":["1.14.11"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp","purl":"pkg:composer/simplesamlphp/simplesamlphp","source":"GHSA-p9cm-r7jg-8q3g"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-9954"},"products":["n/a"],"published":"2017-02-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can spoof SAML signatures or cause denial of service via improper boolean conversion in SimpleSAMLphp.","url":"https://insights.sbomify.com/CVE-2016-9955/"}