CVE-2017-0247 ASP.NET Core fails to properly validate web requests

High 7.5 Published Updated

Remote attackers can cause a denial of service in ASP.NET Core applications by exploiting improper validation of Unicode characters in web requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-0247?

CVE-2017-0247 is a high-severity denial of service vulnerability in Microsoft Corporation ASP.NET Core, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A denial of service vulnerability exists when the ASP.NET Core fails to properly validate web requests. NOTE: Microsoft has not commented on third-party claims that the issue is that the TextEncoder.EncodeCore function in the System.Text.Encodings.Web package in ASP.NET Core Mvc before 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to cause a denial of service by leveraging failure to properly calculate the length of 4-byte characters in the Unicode Non-Character range.

Weakness: CWE-20

Which versions are affected by CVE-2017-0247?

40 open source packages ship an affected version, including Microsoft.AspNetCore.Mvc, Microsoft.AspNetCore.Mvc.Abstractions and Microsoft.AspNetCore.Mvc.ApiExplorer. It affects 18 products.

PackageAffectedFixed in
Microsoft.AspNetCore.Mvc NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Abstractions NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Abstractions NuGetFrom 1.0.01.0.4
34 more packages
Microsoft.AspNetCore.Mvc.Abstractions NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Abstractions NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.ApiExplorer NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.ApiExplorer NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.ApiExplorer NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.ApiExplorer NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Core NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Core NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Core NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Core NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Cors NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Cors NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Cors NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Cors NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.DataAnnotations NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.DataAnnotations NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.DataAnnotations NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.DataAnnotations NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Formatters.Json NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Formatters.Json NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Formatters.Json NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Formatters.Json NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Formatters.Xml NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Formatters.Xml NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Formatters.Xml NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Formatters.Xml NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Localization NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Localization NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Localization NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Localization NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Razor NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Razor NuGetFrom 1.0.01.0.4
Microsoft.AspNetCore.Mvc.Razor NuGetFrom 1.1.01.1.3
Microsoft.AspNetCore.Mvc.Razor NuGetFrom 1.1.01.1.3

Products include Microsoft Asp.net Model View Controller, Microsoft Microsoft.aspnetcore.mvc.abstractions, Microsoft Microsoft.aspnetcore.mvc.apiexplorer, Microsoft Microsoft.aspnetcore.mvc.cors, Microsoft Microsoft.aspnetcore.mvc.dataannotations, Microsoft Microsoft.aspnetcore.mvc.formatters.json and 12 more.

How do I fix CVE-2017-0247?

Upgrade Microsoft.AspNetCore.Mvc to a fixed version for your release line: 1.0.4 or 1.1.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2017-0247 being exploited?

There is no known exploitation of CVE-2017-0247 in the wild and no public exploit code.

Sources

Also known as ECHO-bc40-6686-bc02, GHSA-6xh7-4v2w-36q6.

Is CVE-2017-0247 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free