{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-0357 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-0357 is a critical memory corruption vulnerability in Debian Debian Linux, published on 13 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-0357 and fix it if it is affected.\n\nWhat it is: CVE-2017-0357 is a critical memory corruption vulnerability in Debian Debian Linux, published on 13 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-0357 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-0357/ (Markdown: https://insights.sbomify.com/CVE-2017-0357/index.md)","id":"CVE-2017-0357","markdown":"https://insights.sbomify.com/CVE-2017-0357/index.md","name":"CVE-2017-0357","record":{"aliases":["DEBIAN-CVE-2017-0357","GHSA-29vx-f64r-92xh","UBUNTU-CVE-2017-0357","USN-3186-1","openSUSE-SU-2024:10867-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Linux firmware tool","requires_auth":"none","summary":"A heap buffer overflow in iucode-tool allows attackers to cause a crash or potentially execute arbitrary code via a crafted microcode file.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"iucode-tool","vendor":"iucode-tool_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"iucode-tool: heap buffer overflow on -tr loader","id":"CVE-2017-0357","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"memory_corruption","year":"2017"},"n_packages":1,"n_references":3,"next":{"headline":"ntfs-3g: Modprobe influence vulnerability via environment variables","id":"CVE-2017-0358"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.3.1-1.13"],"introduced":["0"],"last_affected":[],"package":"iucode-tool","purl":"pkg:rpm/opensuse/iucode-tool\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10867-1"}],"prev":{"headline":"Authentication bypass via repeated parameters","id":"CVE-2017-0356"},"products":["iucode-tool"],"published":"2018-04-13","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["iucode-tool"]},"summary":"A heap buffer overflow in iucode-tool allows attackers to cause a crash or potentially execute arbitrary code via a crafted microcode file.","url":"https://insights.sbomify.com/CVE-2017-0357/"}