# CVE-2017-0360: Tryton Information Disclosure Vulnerability

> Authenticated attackers can read arbitrary files on the server via a path traversal flaw in the file opening mechanism.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-0360, DLA-882-1, DSA-3826-1, GHSA-7cwg-2575-3546, PYSEC-2017-97, UBUNTU-CVE-2017-0360

## What is CVE-2017-0360?

CVE-2017-0360 is a medium-severity path traversal vulnerability in tryton-server before 3.4.0-3+deb8u3, published on 4 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

file_open in Tryton 3.x and 4.x through 4.2.2 allows remote authenticated users with certain permissions to read arbitrary files via a "same root name but with a suffix" attack. NOTE: This vulnerability exists because of an incomplete fix for CVE-2016-1242.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-0360?

15 open source packages ship an affected version, including trytond. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trytond` | PyPI | From 3 | 4.2.3 |
| `trytond` | PyPI | From 3.0.0 to 3.0.17 | None |
| `trytond` | PyPI | From 3.0.0 to 3.0.17 | None |
| `trytond` | PyPI | From 3.2.0 to 3.2.17 | None |
| `trytond` | PyPI | From 3.2.0 to 3.2.17 | None |
| `trytond` | PyPI | From 3.4.0 to 3.4.17 | None |
| `trytond` | PyPI | From 3.4.0 to 3.4.17 | None |
| `trytond` | PyPI | From 3.6.0 to 3.6.16 | None |
| `trytond` | PyPI | From 3.6.0 to 3.6.16 | None |
| `trytond` | PyPI | From 3.8.0 to 3.8.14 | None |
| `trytond` | PyPI | From 3.8.0 to 3.8.14 | None |
| `trytond` | PyPI | From 4.0.0 to 4.0.9 | None |
| `trytond` | PyPI | From 4.0.0 to 4.0.9 | None |
| `trytond` | PyPI | From 4.2.0 | 4.2.3 |
| `trytond` | PyPI | From 4.2.0 | 4.2.3 |

Products: Tryton Tryton.

## How do I fix CVE-2017-0360?

Upgrade trytond to 4.2.3 or later.

## Is CVE-2017-0360 being exploited?

There is no known exploitation of CVE-2017-0360 in the wild and no public exploit code.

## Other vulnerabilities in tryton-server before 3.4.0-3+deb8u3

- [CVE-2014-6633](https://insights.sbomify.com/CVE-2014-6633/): Tryton vulnerable to arbitrary command execution (high 8.8)
- [CVE-2013-4510](https://insights.sbomify.com/CVE-2013-4510/): Tryton Directory Traversal vulnerability (high 7.8)
- [CVE-2018-19443](https://insights.sbomify.com/CVE-2018-19443/): Session Fixation in Tryton (medium 5.9)
- [CVE-2016-1241](https://insights.sbomify.com/CVE-2016-1241/): Tryton allows users to read the hashed password (medium 5.3)
- [CVE-2016-1242](https://insights.sbomify.com/CVE-2016-1242/): Tryton allow authenticated users with certain permissions to read arbitrary files via the name parameter (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-0360 and fix it if it is affected.

What it is: CVE-2017-0360 is a medium-severity path traversal vulnerability in tryton-server before 3.4.0-3+deb8u3, published on 4 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-0360 in the wild and no public exploit code.

Affected packages and fixed versions:
- trytond (PyPI): affected from 3; fixed in 4.2.3
- trytond (PyPI): affected from 3.0.0 up to 3.0.17; no fix listed
- trytond (PyPI): affected from 3.0.0 up to 3.0.17; no fix listed
- trytond (PyPI): affected from 3.2.0 up to 3.2.17; no fix listed
- trytond (PyPI): affected from 3.2.0 up to 3.2.17; no fix listed
- trytond (PyPI): affected from 3.4.0 up to 3.4.17; no fix listed
- trytond (PyPI): affected from 3.4.0 up to 3.4.17; no fix listed
- trytond (PyPI): affected from 3.6.0 up to 3.6.16; no fix listed
- trytond (PyPI): affected from 3.6.0 up to 3.6.16; no fix listed
- trytond (PyPI): affected from 3.8.0 up to 3.8.14; no fix listed
- trytond (PyPI): affected from 3.8.0 up to 3.8.14; no fix listed
- trytond (PyPI): affected from 4.0.0 up to 4.0.9; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-0360/ (Markdown: https://insights.sbomify.com/CVE-2017-0360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-0360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-0360
- OSV: https://osv.dev/vulnerability/CVE-2017-0360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-0360/
Summaries are generated and may contain mistakes; the official description above is the record.
