{"answers":{"affected":"2 open source packages ship an affected version, including paperclip. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-0889 in the wild and no public exploit code.","fix":"Upgrade paperclip to 5.2.0 or later.","what":"CVE-2017-0889 is a critical server-side request forgery vulnerability in thoughtbot paperclip ruby gem, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-0889 and fix it if it is affected.\n\nWhat it is: CVE-2017-0889 is a critical server-side request forgery vulnerability in thoughtbot paperclip ruby gem, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-0889 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paperclip (RubyGems): affected from 3.1.4; fixed in 5.2.0\n- paperclip (RubyGems): affected from 3.1.4; fixed in 5.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-0889/ (Markdown: https://insights.sbomify.com/CVE-2017-0889/index.md)","id":"CVE-2017-0889","markdown":"https://insights.sbomify.com/CVE-2017-0889/index.md","name":"CVE-2017-0889","record":{"aliases":["GHSA-5jcf-c5rg-rmm8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby file attachment library","requires_auth":"none","summary":"Attackers can exploit a Server-Side Request Forgery flaw in the Paperclip gem to access internal network resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"paperclip","vendor":"thoughtbot"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"paperclip Server-Side Request Forgery vulnerability","id":"CVE-2017-0889","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"ssrf","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in Nextcloud Server","id":"CVE-2017-0890"},"packages":[{"ecosystem":"RubyGems","fixed":["5.2.0"],"introduced":["3.1.4"],"last_affected":[],"package":"paperclip","purl":null,"source":"GHSA-5jcf-c5rg-rmm8"},{"ecosystem":"RubyGems","fixed":["5.2.0"],"introduced":["3.1.4"],"last_affected":[],"package":"paperclip","purl":"pkg:gem/paperclip","source":"GHSA-5jcf-c5rg-rmm8"}],"prev":{"headline":"Cross-site scripting in Nextcloud Server","id":"CVE-2017-0888"},"products":["paperclip ruby gem"],"published":"2017-11-13","related":[{"cvss_score":4.3,"headline":"paperclip Cross-site Scripting vulnerability","id":"CVE-2015-2963","kev_date_added":null,"published":"2015-07-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["thoughtbot"]},"summary":"Attackers can exploit a Server-Side Request Forgery flaw in the Paperclip gem to access internal network resources.","url":"https://insights.sbomify.com/CVE-2017-0889/"}