# CVE-2017-0889: paperclip Server-Side Request Forgery vulnerability

> Attackers can exploit a Server-Side Request Forgery flaw in the Paperclip gem to access internal network resources.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5jcf-c5rg-rmm8

## What is CVE-2017-0889?

CVE-2017-0889 is a critical server-side request forgery vulnerability in thoughtbot paperclip ruby gem, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2017-0889?

2 open source packages ship an affected version, including paperclip. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paperclip` | RubyGems | From 3.1.4 | 5.2.0 |
| `paperclip` | RubyGems | From 3.1.4 | 5.2.0 |

Products: Thoughtbot Paperclip.

## How do I fix CVE-2017-0889?

Upgrade paperclip to 5.2.0 or later.

## Is CVE-2017-0889 being exploited?

There is no known exploitation of CVE-2017-0889 in the wild and no public exploit code.

## Other vulnerabilities in thoughtbot paperclip ruby gem

- [CVE-2015-2963](https://insights.sbomify.com/CVE-2015-2963/): paperclip Cross-site Scripting vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-0889 and fix it if it is affected.

What it is: CVE-2017-0889 is a critical server-side request forgery vulnerability in thoughtbot paperclip ruby gem, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-0889 in the wild and no public exploit code.

Affected packages and fixed versions:
- paperclip (RubyGems): affected from 3.1.4; fixed in 5.2.0
- paperclip (RubyGems): affected from 3.1.4; fixed in 5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-0889/ (Markdown: https://insights.sbomify.com/CVE-2017-0889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-0889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-0889
- OSV: https://osv.dev/vulnerability/CVE-2017-0889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-0889/
Summaries are generated and may contain mistakes; the official description above is the record.
