CVE-2017-0899 RubyGems Code Injection vulnerability

Critical 9.8 Published Updated

Attackers can execute arbitrary code via terminal escape sequences in malicious gem specifications when printed by RubyGems.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-0899?

CVE-2017-0899 is a critical code injection vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

Weakness: CWE-94, CWE-150

Which versions are affected by CVE-2017-0899?

2 open source packages ship an affected version, including rubygems-update. It affects 8 products.

PackageAffectedFixed in
rubygems-update RubyGemsAll versions2.6.13
rubygems-update RubyGemsAll versions2.6.13

Products include Debian Debian Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus and 2 more.

How do I fix CVE-2017-0899?

Upgrade rubygems-update to 2.6.13 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2017-0899 being exploited?

There is no known exploitation of CVE-2017-0899 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2017-0899, CLEANSTART-2026-VB58893, DEBIAN-CVE-2017-0899, GHSA-7gcp-2gmq-w3xh, UBUNTU-CVE-2017-0899.

Is CVE-2017-0899 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free