{"answers":{"affected":"2 open source packages ship an affected version, including rubygems-update. It affects 8 products.","exploited":"There is no known exploitation of CVE-2017-0899 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to 2.6.13 or later.","what":"CVE-2017-0899 is a critical code injection vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-0899 and fix it if it is affected.\n\nWhat it is: CVE-2017-0899 is a critical code injection vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-0899 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13\n- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-0899/ (Markdown: https://insights.sbomify.com/CVE-2017-0899/index.md)","id":"CVE-2017-0899","markdown":"https://insights.sbomify.com/CVE-2017-0899/index.md","name":"CVE-2017-0899","record":{"aliases":["ALPINE-CVE-2017-0899","CLEANSTART-2026-VB58893","DEBIAN-CVE-2017-0899","GHSA-7gcp-2gmq-w3xh","UBUNTU-CVE-2017-0899"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can execute arbitrary code via terminal escape sequences in malicious gem specifications when printed by RubyGems.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_server_aus","vendor":"redhat"},{"product":"enterprise_linux_server_eus","vendor":"redhat"},{"product":"enterprise_linux_server_tus","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Code Injection vulnerability","id":"CVE-2017-0899","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_server_aus","redhat:enterprise_linux_server_eus","redhat:enterprise_linux_server_tus","redhat:enterprise_linux_workstation"],"type":"code_injection","year":"2017"},"n_packages":2,"n_references":13,"next":{"headline":"RubyGems Improper Input Validation vulnerability","id":"CVE-2017-0900"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.13"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-7gcp-2gmq-w3xh"},{"ecosystem":"RubyGems","fixed":["2.6.13"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-7gcp-2gmq-w3xh"}],"prev":{"headline":"Memory corruption in Ruby","id":"CVE-2017-0898"},"products":["RubyGems"],"published":"2017-08-31","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary code via terminal escape sequences in malicious gem specifications when printed by RubyGems.","url":"https://insights.sbomify.com/CVE-2017-0899/"}