# CVE-2017-0899: RubyGems Code Injection vulnerability

> Attackers can execute arbitrary code via terminal escape sequences in malicious gem specifications when printed by RubyGems.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2017
- **Updated:** 17 Sep 2024
- **Also known as:** ALPINE-CVE-2017-0899, CLEANSTART-2026-VB58893, DEBIAN-CVE-2017-0899, GHSA-7gcp-2gmq-w3xh, UBUNTU-CVE-2017-0899

## What is CVE-2017-0899?

CVE-2017-0899 is a critical code injection vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2017-0899?

2 open source packages ship an affected version, including rubygems-update. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubygems-update` | RubyGems | All versions | 2.6.13 |
| `rubygems-update` | RubyGems | All versions | 2.6.13 |

Products: Debian Debian Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus, Redhat Enterprise Linux Workstation, Rubygems Rubygems.

## How do I fix CVE-2017-0899?

Upgrade rubygems-update to 2.6.13 or later.

## Is CVE-2017-0899 being exploited?

There is no known exploitation of CVE-2017-0899 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-0899 and fix it if it is affected.

What it is: CVE-2017-0899 is a critical code injection vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-0899 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13
- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-0899/ (Markdown: https://insights.sbomify.com/CVE-2017-0899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-0899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-0899
- OSV: https://osv.dev/vulnerability/CVE-2017-0899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-0899/
Summaries are generated and may contain mistakes; the official description above is the record.
