CVE-2017-0900 RubyGems Improper Input Validation vulnerability

High 7.5 Published Updated

Attackers can cause denial of service against RubyGems clients by sending maliciously crafted gem specifications during query commands.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-0900?

CVE-2017-0900 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.

Weakness: CWE-20

Which versions are affected by CVE-2017-0900?

2 open source packages ship an affected version, including rubygems-update. It affects 8 products.

PackageAffectedFixed in
rubygems-update RubyGemsAll versions2.6.13
rubygems-update RubyGemsAll versions2.6.13

Products include Debian Debian Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus and 2 more.

How do I fix CVE-2017-0900?

Upgrade rubygems-update to 2.6.13 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2017-0900 being exploited?

There is no known exploitation of CVE-2017-0900 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2017-0900, CLEANSTART-2026-RN88749, DEBIAN-CVE-2017-0900, GHSA-p7f2-rr42-m9xm, UBUNTU-CVE-2017-0900.

Is CVE-2017-0900 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free