{"answers":{"affected":"2 open source packages ship an affected version, including rubygems-update. It affects 9 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-0901 exists.","fix":"Upgrade rubygems-update to 2.6.13 or later.","what":"CVE-2017-0901 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-0901 and fix it if it is affected.\n\nWhat it is: CVE-2017-0901 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-0901 exists.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13\n- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-0901/ (Markdown: https://insights.sbomify.com/CVE-2017-0901/index.md)","id":"CVE-2017-0901","markdown":"https://insights.sbomify.com/CVE-2017-0901/index.md","name":"CVE-2017-0901","record":{"aliases":["ALPINE-CVE-2017-0901","CLEANSTART-2026-HJ73533","DEBIAN-CVE-2017-0901","GHSA-pm9x-4392-2c2p","UBUNTU-CVE-2017-0901"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can overwrite arbitrary files via malicious gem specification names, potentially leading to code execution or system compromise.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_server_aus","vendor":"redhat"},{"product":"enterprise_linux_server_eus","vendor":"redhat"},{"product":"enterprise_linux_server_tus","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.","ecosystems":["RubyGems"],"exploits":{"exploitdb":1,"first_seen":"2017-09-04","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-09-04","kind":"exploitdb","ref":"42611","stars":null,"title":"RubyGems \u003c 2.6.13 - Arbitrary File Overwrite"}],"tier":"weaponised"},"has_fix":true,"headline":"RubyGems may allow a maliciously crafted gem to overwrite files","id":"CVE-2017-0901","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_server_aus","redhat:enterprise_linux_server_eus","redhat:enterprise_linux_server_tus","redhat:enterprise_linux_workstation"],"type":"path_traversal","year":"2017"},"n_packages":2,"n_references":15,"next":{"headline":"RubyGems has Origin Validation Error vulnerability","id":"CVE-2017-0902"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.13"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-pm9x-4392-2c2p"},{"ecosystem":"RubyGems","fixed":["2.6.13"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-pm9x-4392-2c2p"}],"prev":{"headline":"RubyGems Improper Input Validation vulnerability","id":"CVE-2017-0900"},"products":["RubyGems"],"published":"2017-08-31","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can overwrite arbitrary files via malicious gem specification names, potentially leading to code execution or system compromise.","url":"https://insights.sbomify.com/CVE-2017-0901/"}