CVE-2017-0902 RubyGems has Origin Validation Error vulnerability

High 8.1 Published Updated

A DNS hijacking vulnerability in RubyGems allows attackers to force clients to install malicious gems, leading to arbitrary code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-0902?

CVE-2017-0902 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

Weakness: CWE-346, CWE-350

Which versions are affected by CVE-2017-0902?

2 open source packages ship an affected version, including rubygems-update. It affects 9 products.

PackageAffectedFixed in
rubygems-update RubyGemsAll versions2.6.13
rubygems-update RubyGemsAll versions2.6.13

Products include Canonical Ubuntu Linux, Debian Debian Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus and 3 more.

How do I fix CVE-2017-0902?

Upgrade rubygems-update to 2.6.13 or later.

Is CVE-2017-0902 being exploited?

There is no known exploitation of CVE-2017-0902 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2017-0902, CLEANSTART-2026-FO70929, DEBIAN-CVE-2017-0902, GHSA-73w7-6w9g-gc8w, UBUNTU-CVE-2017-0902.

Is CVE-2017-0902 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free