# CVE-2017-0902: RubyGems has Origin Validation Error vulnerability

> A DNS hijacking vulnerability in RubyGems allows attackers to force clients to install malicious gems, leading to arbitrary code execution.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2017
- **Updated:** 17 Sep 2024
- **Also known as:** ALPINE-CVE-2017-0902, CLEANSTART-2026-FO70929, DEBIAN-CVE-2017-0902, GHSA-73w7-6w9g-gc8w, UBUNTU-CVE-2017-0902

## What is CVE-2017-0902?

CVE-2017-0902 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

Weakness: CWE-346 (Origin Validation Error), CWE-350 (Reliance on Reverse DNS Resolution for a Security-Critical Action)

## Which versions are affected by CVE-2017-0902?

2 open source packages ship an affected version, including rubygems-update. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubygems-update` | RubyGems | All versions | 2.6.13 |
| `rubygems-update` | RubyGems | All versions | 2.6.13 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus, Redhat Enterprise Linux Workstation, Rubygems Rubygems.

## How do I fix CVE-2017-0902?

Upgrade rubygems-update to 2.6.13 or later.

## Is CVE-2017-0902 being exploited?

There is no known exploitation of CVE-2017-0902 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-0902 and fix it if it is affected.

What it is: CVE-2017-0902 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-0902 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13
- rubygems-update (RubyGems): affected all versions; fixed in 2.6.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-0902/ (Markdown: https://insights.sbomify.com/CVE-2017-0902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-0902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-0902
- OSV: https://osv.dev/vulnerability/CVE-2017-0902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-0902/
Summaries are generated and may contain mistakes; the official description above is the record.
