CVE-2017-0903 RubyGems vulnerable to Deserialization of Untrusted Data
Attackers can achieve remote code execution by exploiting unsafe YAML deserialization in RubyGems gem specifications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-0903?
CVE-2017-0903 is a critical unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 11 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.
Weakness: CWE-502
Which versions are affected by CVE-2017-0903?
2 open source packages ship an affected version, including rubygems-update. It affects 9 products.
| Package | Affected | Fixed in |
|---|---|---|
rubygems-update RubyGems | From 2.0.0 | 2.6.14 |
rubygems-update RubyGems | From 2.0.0 | 2.6.14 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus and 3 more.
How do I fix CVE-2017-0903?
Upgrade rubygems-update to 2.6.14 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2017-0903 being exploited?
There is no known exploitation of CVE-2017-0903 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2017-0903, GHSA-mqwr-4qf2-2hcv, UBUNTU-CVE-2017-0903, USN-3685-2.