{"answers":{"affected":"2 open source packages ship an affected version, including rubygems-update. It affects 9 products.","exploited":"There is no known exploitation of CVE-2017-0903 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to 2.6.14 or later.","what":"CVE-2017-0903 is a critical unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 11 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-0903 and fix it if it is affected.\n\nWhat it is: CVE-2017-0903 is a critical unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 11 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-0903 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected from 2.0.0; fixed in 2.6.14\n- rubygems-update (RubyGems): affected from 2.0.0; fixed in 2.6.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-0903/ (Markdown: https://insights.sbomify.com/CVE-2017-0903/index.md)","id":"CVE-2017-0903","markdown":"https://insights.sbomify.com/CVE-2017-0903/index.md","name":"CVE-2017-0903","record":{"aliases":["DEBIAN-CVE-2017-0903","GHSA-mqwr-4qf2-2hcv","UBUNTU-CVE-2017-0903","USN-3685-2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can achieve remote code execution by exploiting unsafe YAML deserialization in RubyGems gem specifications.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_server_aus","vendor":"redhat"},{"product":"enterprise_linux_server_eus","vendor":"redhat"},{"product":"enterprise_linux_server_tus","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems vulnerable to Deserialization of Untrusted Data","id":"CVE-2017-0903","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_server_aus","redhat:enterprise_linux_server_eus","redhat:enterprise_linux_server_tus","redhat:enterprise_linux_workstation"],"type":"deserialization","year":"2017"},"n_packages":2,"n_references":13,"next":{"headline":"private_address_check vulnerable to bypass of Resolv.getaddresses method","id":"CVE-2017-0904"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.14"],"introduced":["2.0.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-mqwr-4qf2-2hcv"},{"ecosystem":"RubyGems","fixed":["2.6.14"],"introduced":["2.0.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-mqwr-4qf2-2hcv"}],"prev":{"headline":"RubyGems has Origin Validation Error vulnerability","id":"CVE-2017-0902"},"products":["RubyGems"],"published":"2017-10-11","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can achieve remote code execution by exploiting unsafe YAML deserialization in RubyGems gem specifications.","url":"https://insights.sbomify.com/CVE-2017-0903/"}