CVE-2017-0906 Recurly vulnerable to SSRF
An SSRF vulnerability in the Recurly Python library allows attackers to compromise API keys and access critical resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-0906?
CVE-2017-0906 is a critical server-side request forgery vulnerability in recurly python module, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.
Weakness: CWE-918
Which versions are affected by CVE-2017-0906?
15 open source packages ship an affected version, including recurly. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
recurly PyPI | All versions | 2.0.5 |
recurly PyPI | All versions | 2.0.5 |
recurly PyPI | From 2.0 | 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 |
recurly PyPI | From 2.1.0 | 2.1.16 |
recurly PyPI | From 2.1.0 | 2.1.16 |
recurly PyPI | From 2.2.0 | 2.2.22 |
9 more packages
recurly PyPI | From 2.2.0 | 2.2.22 |
recurly PyPI | From 2.3.0 | 2.3.1 |
recurly PyPI | From 2.3.0 | 2.3.1 |
recurly PyPI | From 2.4.0 | 2.4.5 |
recurly PyPI | From 2.4.0 | 2.4.5 |
recurly PyPI | From 2.5.0 | 2.5.1 |
recurly PyPI | From 2.5.0 | 2.5.1 |
recurly PyPI | From 2.6.0 | 2.6.2 |
recurly PyPI | From 2.6.0 | 2.6.2 |
Products include Recurly Recurly Client Python.
How do I fix CVE-2017-0906?
Upgrade recurly to a fixed version for your release line: 2.0.5, 2.1.16, 2.2.22 or 2.3.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2017-0906 being exploited?
There is no known exploitation of CVE-2017-0906 in the wild and no public exploit code.
Sources
Also known as GHSA-38rv-5jqc-m2cv, PYSEC-2017-68.